Poseidon is not working

  • IGN: Filosofas_HW

    Server: Pi
    Issue: active Poseidon is not working properly. In the transportation window, it shows speed value doubled as before, however, when you send your ships, after loading time, they travel at default speed (no speed boost provided). I have level 5 Poseidon.


    Edit: my alliance mates are experiencing the same issue, it's probably a new bug that came out with language update.

  • Looks intermittent. 1 pillage attempt regular speed. Next half time. Return regular :(.

    Viet Nam Sociality[VNS] - Alpha US Spokesman
    Bậc Thầy Thịt mèo Nướng

    BBQ CAT Master Chef

  • I have same problem on the US server.


    I searched and found this forum but not sure if this is a general forum or if I need to report this problem in a US specific forum. I did see a selection for region or language. I chose EN because I speak EN and did not see an entry for US.

  • Doesn't work for me either...

    "On the contrary, woman is the best equipped machine ever went to battle"

    -Richard Le Gallienne

    edited-image_8.png

    "Asking polite with a gun in your hand is better than asking polite with nothing"



  • Yep, Poseidon has not been working on Beta Server also from last night.

    Anyone has any ideas when its gonna be sorted out ?

  • For me Poseidon works OK moving fleet and troops. The only issues is when moving goods.

    Tested, that's true. For some people, it works for 1 way and doesn't work when coming back (didn't try to 100% verify).

    Yep, Poseidon has not been working on Beta Server also from last night.

    Anyone has any ideas when its gonna be sorted out ?

    After the merge lesser bugs (missing fleets, slow servers) were fixed in 1 - 2 weeks, so I guess the same will apply now. Granted, I am not a team member and this is purely based on previous observations, which may or may not be right. I just think it's unreasonable to go around and ask when it will be fixed without giving a week or two to actually do it :)

  • Will ambro be reimbursed for all those over the past three weeks affected by cargo compression failure, then poseidon meltdown and also ambro triton boost inoperable?


    Local arch bishops and rocket scientists agree that all these issues are related

  • Triton engine got broken only a few days ago, so I don't see what ambrosia should be reimbursed for those who were not able to use the draft feature? And who/how would determine who is eligible for that - everyone who has sent the trading ships at least once in the last few weeks? 8o

  • yes but I was compelled to use triton to make up for compression and then in the blur I carried on using whatever I could to get troops and ships into battle and trade - it took some time to figure out what was broken and it wasn't universal at first - some people were affected some not - confusing times


    to add to it because travel times now so lengthened I have been forced to use more mercenary shippers - some ambro back for that would be appreciated too


    I see Badidol has recently posted on news about hopeful fix for Tuesday - interesting


    but yeah I think any intelligent ambro user would agree that some adjustment would be fair in light of these events - not to mention contractually GF are not now delivering product as advertised etc I am not a lawyer but they love stuff like this

  • Very true but a generous compensatory gesture when the merge dust has settled would ward off those legal beagle hounds :-)


    and as an effect of slow movement and trade I may have to vmode for a while as I cannot keep Black Markets free of attack for long enough to make coin sales


    me vmode = no ambro used - and I'm sure this applies to others